Engage: Feeds failing to load, replies to Facebook and Instagram content failing to send

Incident Report for Brandwatch

Resolved

This incident has been resolved.
Thank you for your patience and understanding.
Posted Aug 18, 2025 - 09:49 UTC

Monitoring

A fix has been implemented, and the Engage module should now be working as expected.
We are actively monitoring to ensure everything remains stable.
Thank you for your patience.
Posted Aug 18, 2025 - 08:29 UTC

Investigating

We are currently aware of an issue with Engage feeds failing to load or loading with a delay, and replies sent to Facebook and Instagram content failing to send.

Our Technical team has been advised and we're treating this as a priority, and will provide all updates as swiftly as possible.

We apologise for any inconvenience and frustration this issue has caused.
Posted Aug 18, 2025 - 06:44 UTC
This incident affected: Social Media Management (Engage).