SMM: Platform not loading
Incident Report for Brandwatch
Resolved
This incident has been resolved.
Posted Nov 20, 2024 - 12:40 UTC
Investigating
We are currently investigating this issue.
Posted Nov 20, 2024 - 12:32 UTC
This incident affected: Social Media Management (Platform (Falcon)).