Consumer Research - Intermittent Issue with Results Not Loading

Incident Report for Brandwatch

Resolved

Thank you for your patience. This issue is now resolved.
Posted Sep 09, 2026 - 15:40 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 09, 2026 - 10:46 UTC

Investigating

We're currently experiencing intermittent issues with results not loading in Query Explore and Dashboards, and our Engineering team is investigating the cause.
Posted Sep 08, 2026 - 22:15 UTC
This incident affected: Consumer Intelligence (Consumer Research Application).