Settings: Add channels button not responding

Incident Report for Brandwatch

Resolved

This incident has been resolved.
Posted Nov 24, 2023 - 07:26 UTC

Update

We are continuing to investigate this issue.
Posted Nov 24, 2023 - 07:05 UTC

Investigating

We are currently experiencing an issue with our 'add channels' button, as it is not responding and preventing new connections being made to our platform. At this stage, no workaround has been identified.

Our Development team has been notified, and we are treating this issue with a high priority. Updates will be provided as soon as they are available.

We thank you for your patience, and apologise for the inconvenience caused.
Posted Nov 24, 2023 - 00:51 UTC
This incident affected: Social Media Management (Platform (Falcon)).