Meta (Facebook and Instagram) Data Delays

Incident Report for Brandwatch

Resolved

Thank you for your patience. Meta has confirmed all issues are resolved.
Posted Jun 12, 2026 - 19:20 UTC

Update

Per Meta's status page (metastatus.com), some of the instability is resolved, while other functionality remains degraded. We are continuing to monitor closely.
Posted Jun 12, 2026 - 17:08 UTC

Monitoring

We are aware that Facebook and Instagram are having stability issues natively, including users being unable to log in.
We are currently unable to capture Facebook and Instagram data due to this disruption. Our Engineering teams are monitoring the situation closely.
Posted Jun 12, 2026 - 14:25 UTC
This incident affected: Consumer Intelligence (Data Collection) and Social Media Management (Platform, Publish, Engage, Audience, Advertise, Measure, Benchmark, Listen, Filestack API, Cloud Elements EU Production, Influence (Paladin)).