[Analytics, Consumer Research, Audiences] Issues logging into platform
Incident Report for Brandwatch
Resolved
This incident has been resolved.
Posted Feb 24, 2020 - 21:10 UTC
Investigating
We are currently investigating this issue.
Posted Feb 24, 2020 - 21:06 UTC
This incident affected: Consumer Intelligence (Consumer Research Application).