Users are not able to View and Modify Users in accounts.brandwatch.com
Incident Report for Brandwatch
Resolved
This incident has been resolved
Posted Oct 25, 2021 - 15:06 UTC
Investigating
When accessing accounts.brandwatch.com Users are given an "Invalid Token" error message and are unable to view and modify Users in accounts.brandwatch.com.

Our Engineers are working to rectify this issue as soon as possible.
Posted Oct 25, 2021 - 14:58 UTC
This incident affected: Consumer Intelligence (Consumer Research Application, Data Collection).