[Consumer Research] - Users may experience issues logging in and using BCR
Incident Report for Brandwatch
Resolved
This incident has been resolved.
Posted Apr 03, 2024 - 12:31 UTC
Update
We are continuing to investigate this issue.
Posted Apr 03, 2024 - 11:51 UTC
Investigating
We are currently investigating this issue.
Posted Apr 03, 2024 - 11:30 UTC
This incident affected: Consumer Intelligence (Consumer Research Application).